Was kann die Ursache sein, das von OpenWrt kein Internet Zugriff möglich ist?

Was kann die Ursache sein, das von OpenWrt kein Zugriff auf das Internet möglich ist?
Checken ob: ping wenzlaff.de geht, wenn nicht,
dann in der /etc/confi/network Datei überprüfen,
ob der folgende Eintrag mit dem DNS und Gateway vorhanden ist:

config interface ‘lan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.2.122’
option netmask ‘255.255.255.0’
option ip6assign ’60’
option dns ‘xxx.xxx.xxx.xxx’ # IP-Adresse aus Router eintragen
option gateway ‘192.168.2.1’

Das Netzwerkkabel muss am Router angeschlossen werden und nicht an der Netzwerkkarte des Rechners.

Wie kann auf den TL-WR703N Fhem installiert werden?

Dazu muss erst einmal mehr Speicher per USB-Stick bereitgestellt werden.

Dann gem. dieser Anleitung vorgehen.

Also kurz:
1. OpenWrt installieren
2. USB-Stick vorbereiten und an WR703N anschließen
3. Perl installieren
4. Fhem aus Subversion ausschecken
5. mit make install Fhem erstellen
6. nun kann Fhem gestartet werden in /usr/src/fhem mit: perl /opt/fhem/fhem.pl /opt/fhem/fhem.cfg
7. im Browser http://192.168.2.122:8083/fhem (ip anpassen) aufrufen, es kommt:

Fhem Startbildschirm auf WR-703N mit OpenWrt
Fhem Startbildschirm auf WR-703N mit OpenWrt

8. Autostart für Fhem einrichten. Datei /etc/init.d/fhem anlegen mit folgenden Inhalt:

#!/bin/sh /etc/rc.common
# FHEM Init Script
START=11
STOP=15
start() {
# cd /usr/src/fhem/
# perl /opt/fhem/fhem.pl /opt/fhem/fhem.cfg
# auf neue Verz. angepasst:
cd /etc/src/fhem/
perl /etc/src/fhem/fhem.pl /etc/src/fhem/fhem.cfg
}
stop(){
echo "shutdown" | nc localhost 7072
}

Dann noch die /etc/init.d/fhem Datei ausführbar machen und aktivieren.
chmod +x /etc/init.d/fhem
/etc/init.d/fhem enable
/etc/init.d/fhem start

Nach reboot startet nun Fhem automatisch.

9. Fhem weiter konfigurieren

10. z.B. den ersten Plot anzeigen. Dazu z.B in das Verzeichnis /fhem/www/log die eine Test-Datei temp.log mit Messwerten kopieren. In der /etc/src/fhem.cfg
diese Anpassungen machen:

define Test dummy
define FileLog_Test FileLog /usr/src/fhem/log/temp.log Test
attr FileLog_Test logtype temp4:Plot,text
attr FileLog_Test room Test
define wlTest weblink fileplot FileLog_Test:temp4:CURRENT
attr wlTest room Test

Und schon wird dieses schöne Diagramm angezeigt. Es ist noch nicht viel, da die Testdaten nur ein paar Zeilen sind:

1. Test Plot
1. Test Plot

Wie kann für den TL WR703N ein externer USB-Stick als Speicher verwendet werden?

Wenn der TL WR703N mit OpenWRT 12.09 Attitude Adjustement und Luci 0.11.1 geflasht wurde, bleibt nur noch ca. 870 KB an Speicher frei.

Wie kann nun ein externer USB Stick an den WR703 angeschlossen werden?

1. USB-Stick vorbereiten

Der USB Stick muss vorher, mit ext4 an einen anderen Rechner formatiert werden, da der Speicher dafür nicht ausreicht.
Ich habe einen 8 GB Stick mit einer Partitionen wie folgt erstellt:

8 GB Stick, ext4, primäre Partition, aktive – /dev/sda1

unter Windows erstellt und formatiert mit dem Partition Wizard Home Edition wie in beschrieben.

2. Firmware flashen

Neue Firmware über Luci GUI geflasht, auf 12.09 r36088, da die “alte” Probleme machte.

3. USB-Stick einbinden

Wie in beschrieben vorgegangen.

Dann gem. der Anleitung:

ls /dev/sd*
opkg update

opkg install kmod-usb-storage
opkg install kmod-fs-ext4 block-mount

# ab jetzt ist auch in Luci der Tab vorhanden und zwar unter System – Mount Points

mkdir -p /mnt/sda1
mount /dev/sda1 /mnt/sda1

mkdir -p /tmp/cproot
mount – -bind / /tmp/cproot
tar -C /tmp/cproot -cvf – . | tar -C /mnt/sda1 -xf –

umount /tmp/cproot
umount /mnt/sda1

vi /etc/config/fstab
# in der config mount Sektion
option target /
option enabled 1

reboot
df # zeigt den Speicher an
Bildschirmfoto 2014-07-05 um 10.12.38

Speicher ist nun genug vorhanden. Das kann auch unter Luci angezeigt werden:
Bildschirmfoto 2014-07-05 um 10.14.03
Und die gemachten Änderungen aus der /etc/config/fstab werden so angezeigt:
Bildschirmfoto 2014-07-05 um 10.14.20

Flashen des TP-Link TL-WR703N mit OpenWrt über den seriellen Port und einrichten der Luci Gui

Durch das flashen des TP-Link TL-WR703N mit einem Image unbekannter Herkunft,
hatte das schöne Teil leider seinen Geist aufgegeben.

Es kann aber wiederbelebt werden, aber nur über die Serielle-Schnittstelle die nicht nach draußen geführt ist.
Also musste ich doch die drei Kontakte nach draußen führen. Nach dem öffnen des Geräts, und freilegen der Platine,
sind die drei Kontakte (TX, RX, Masse) schnell lokalisiert, dank der guten Fotos auf http://forums.openpilot.org/blog/52/entry-92-unbrick-wr703n-wifi-router/

Eine gute Anleitung ist hier zu finden

http://wiki.villagetelco.org/index.php?title=Building_a_Serial_Port_for_TL-WR703N
und auch
http://www.bitzof.me/doku.php?id=electronics:wr703n:unbricking

Das größte Problem dabei ist an die kleinen Kontakte, passende Drähte anzulöten. Die Kontakte sind wirklich nur ca. 0,4 mm klein. Gefühlt 0,0000001 mm.
Ein Kollege hatte noch den passenden Draht, der wirklich dünner als ein Haar ist und konnte mir einen Meter überlassen.

Also die Brille gesucht und es hat beim ersten Versuch geklappt.

Das war der komplizierteste Teil.

Um den Mac zu schonen, habe ich das flashen der neuen Firmware auf einen alten Windows-Rechner gemacht.

Was war nötig alles nötig?

1. Den seriellen to USB Adapter cf20… an den WR-703N anschließen:

PIN 4 TX an WR TX
PIN 5 RX an WR RX
PIN 6 GND an WR GND

Achtung! Nicht RX an TX und TX an RX .so wie sonst, dann klappt es nicht und das Terminal Fenster bleib schwarz.

2. Treiber für den cf20 von geladen.
Der Treiber richtet einen virtuell COM Port ein. Port in den Systemeinstellungen auf 115200/8/N/1/XON-XOFF stellen.

3. Putty laden und seriell Einstellungen auf: 115200/8/N/1/XON-XOFF

4. TFtp Server von laden und neue OpenWrt Firmware (openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin) in das Verzeichnis kopieren.
Habe den langen Namen noch gekürzt, in firm.bin.

Install Verzeichnis des TFTP32 Server
Install Verzeichnis des TFTP32 Server

Einstellungen des TFTP Servers
Einstellungen des TFTP Servers

5. Rechner IP Adresse setzten 192.168.1.100. Unter Netzwerkverbindungen-Lan-Verbindung-Allgemein-Eigenschaften-Internetprotokoll-Eigenschaften-Folgende-IP-Adresse verwedne-IP-Adresse.
Wichtig: Verbindung vom Rechner zum WR703N per Ethernet nicht vergessen!

6. Nach verbinden des WR-703N hat man max. 1 Sekunde zeit, im Terminal “tpl” und Enter einzugeben um auf dem Prompt zu kommen.
Beim dritten Versuch hat es bei mir geklappt. Wenn hornet> angezeigt wird, hat man gewonnen.

7. Dann folgende Befehle eingeben:

hornet> tftpboot 0x81000000 openwrt-ar71xx-generic-tl-wr703n-v1-squashfs-factory.bin
hornet> erase 0x9f020000 +0x3c0000
hornet> cp.b 0x81000000 0x9f020000 0x3c0000
hornet> bootm 9f020000

flash

Lösch Befehl
Lösch Befehl

und warten bis alles abgeschlossen ist. Dann Enter drücken und der OpenWrt-Prompt mit OpenWrt-Logo erscheint.

8. Ethernet verbinden. Mit Telnet 192.168.1.1 verbinden und wenn der OpenWrt Prompt kommt,
das Passwort setzen mit passwd. Ab dann ist kein Telnet mehr möglich. Neu verbinden mit SSH.

9. Eine andere statische IP vergeben, die im Namensraum vom DNS Server des Internet Routers liegt vergeben.

10. Per SSH anmelden und das Netzwerk einstellen: /etc/config/network

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.2.123' # feste statische Adresse des Routers
option netmask '255.255.255.0'
option ip6assign '60'
option dns '8.8.8.8' # Adresse des Google dns, oder anderen
option gateway '192.168.2.1' # Adresse des gateway

reboot
Ethernet Kabel an Router anschließen.
ping wenzlaff.de
muss erfolgreich laufen

11. Dann die Web-Gui luci installieren
opkg update
opkg install luci luci-i18n-german luci-theme-bootstrap

12. Web Server starten
/etc/init.d/uhttpd start
und damit es beim nächsten start automatisch läuft:
/etc/init.d/uhttpd enable

13. Im Browser die feste statische Adresse aufrufen und anmelden mit User: root und den vergebenen SSH Passwort anmelden.

Bildschirmfoto 2013-07-11 um 21.53.08

Bildschirmfoto 2013-07-11 um 21.53.45